Results 1 to 1 of 1
  1. #1
    dss15 Guest

    Clutch - weird

    Hi was reading through a very old thread
    http://forum.s15oc.com/showthread.php?p=36188#post36188

    I have a similar problem. Owned the s15 about 4 days (upgrade from an s13). Drove it 900km on my way home - everything was fine, until i stayed a night in a hotel, went outside in the morning to drive off.. .pushed the clutch to the floor, and it started making a terrible grinding noise. No gear would engage. Left it idle for 10 mins, and it worked ok. Funny thing is, it doesn't slip when it hits boost, and isn't particularly crap on take offs after its warm.

    The grinding noise happens almost every time I start it cold though??
    Any ideas or experiences similar?

    Thanks guys

    Dave
    Last edited by dss15; 06-12-2008 at 12:51.

Similar Threads

  1. Weird issues with my 15
    By cyris3d in forum Mechanical & Bodywork
    Replies: 16
    Last Post: 29-10-2019, 16:27
  2. Weird squealing noise
    By Mycool in forum Mechanical & Bodywork
    Replies: 2
    Last Post: 11-08-2015, 18:25
  3. Will this be weird....
    By Blitz668 in forum General S15 Chat
    Replies: 4
    Last Post: 15-04-2013, 05:16
  4. Will this be weird....
    By Blitz668 in forum General S15 Chat
    Replies: 0
    Last Post: 14-04-2013, 01:07
  5. Weird boost issue
    By Topper in forum Electrical & Audio
    Replies: 11
    Last Post: 13-05-2009, 07:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •