Results 1 to 5 of 5
  1. #1
    Brad Guest

    S15 Idle off sometimes

    Hi all,

    In the last three weeks every 3rd or fourth time I start the car it misses for 30secs - 2 minutes. It only happens when I start the car, not at lights, when stopped, etc.
    After pulling the coils out the plugs are OK... But when It misses I can fix it by popping the bonnet and pressing down on the second coil pack to the front of the engine with one finger!?!? Stops immediately when I do this.

    Strange or what? The pack is fine and fires running 16psi - but takes this to get it going.
    Anyone had any similar problems? Ideas?

    Cheers!
    Brad.

  2. #2
    Join Date
    Oct 2005
    Location
    Helsinki, Finland
    Posts
    8,001
    Liked
    5
    Change the coil pack to a different plug and see if it the hesitation moves with it. If it does, then the pack's on it way out. If it stays, check the connector.

  3. #3
    S15R Guest
    i had starting issue with my jap spec once, it was over fueling and f***ed the plugs, dont know how that happen but the was sitting in the garage for a week
    first, very unstable idling, then miss firing, so i bought 4 brand new plugs then it went well

  4. #4
    Brad Guest
    Swapping the coils resolved the issue - one of them is stuffed.
    I am guessing it overheated a fortnight ago when we had 5 38 degree celsius + days in a row!

    Nissan wanted $280 AUD for a new one and splitfire coils give very, very marginal increases in torque...
    Second hand one is on its way. $70 AUD - take that Nissan service department...

    Brad.

  5. #5
    Join Date
    Oct 2005
    Location
    Helsinki, Finland
    Posts
    8,001
    Liked
    5
    I was lucky with coil packs. Some guy on SXOC got the top part of his block replaced and the garage that did it got hold of an S15 block from Japan. Of course, certain bits aren't interchangeable. The coilpacks are one (or four... ). As he's paid for them anyway, he sold them to Meddy and I for ?50 a pair.

    We'll be starting a UK branch of Nissan Japan soon...

Similar Threads

  1. rough idle help ? idle position sensor ?
    By subzero in forum Mechanical & Bodywork
    Replies: 8
    Last Post: 10-06-2009, 23:14
  2. Idle speed
    By BOOSTED in forum General S15 Chat
    Replies: 6
    Last Post: 01-04-2009, 07:46
  3. exhaust pop and bad idle
    By nices15man in forum Mechanical & Bodywork
    Replies: 11
    Last Post: 30-01-2009, 11:11
  4. Smell + bad idle
    By dss15 in forum Mechanical & Bodywork
    Replies: 12
    Last Post: 23-12-2008, 11:36
  5. Overfuelling at Idle
    By Nicely in forum Mechanical & Bodywork
    Replies: 6
    Last Post: 23-11-2005, 12:54

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •