Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2019
    Posts
    4
    Liked
    0

    Weird issues with my 15

    The car sat for a long time. I started to get it up and going again and it wouldn't start. It wanst getting fuel to the rail. I changed the pump and it's getting fuel to the rail but still wont start. But before I go to crank it over this happens


    The engine light blinks really fast and makes a clicking sound as well as something whining from the engine bay.

    Any ideas?

  2. #2
    Join Date
    Aug 2011
    Location
    London
    Posts
    502
    Liked
    17
    That’s very odd, it sounds like a relay that’s not doing it’s job properly, can you trace the clicking noise back to a specific relay and let us know your findings?

  3. #3
    Join Date
    Jun 2019
    Posts
    4
    Liked
    0
    I check all the fuses from the cab and engine bay all are good. I even checked the ecu codes. Just 55. So that's ok. Decided to check all the accessories (ac blower, lights, hazard etc) they all work except my blinkers. Left and right nothing but the hazards work. This is what's happening now. The blinking will stop then if I press the brake it starts again. Also the loud humming seems to be coming from the abs unit. Also once and awhile when turning to ON the wipers turn on just once.

    All the grounds are tight.

  4. #4
    Join Date
    Aug 2011
    Location
    London
    Posts
    502
    Liked
    17
    Have you tried to disconnect the negative of the battery and leave the car without power for 30 minutes or so and then trying again?

Similar Threads

  1. Weird squealing noise
    By Mycool in forum Mechanical & Bodywork
    Replies: 2
    Last Post: 11-08-2015, 18:25
  2. Will this be weird....
    By Blitz668 in forum General S15 Chat
    Replies: 4
    Last Post: 15-04-2013, 05:16
  3. Will this be weird....
    By Blitz668 in forum General S15 Chat
    Replies: 0
    Last Post: 14-04-2013, 01:07
  4. Weird boost issue
    By Topper in forum Electrical & Audio
    Replies: 11
    Last Post: 13-05-2009, 07:38
  5. Clutch - weird
    By dss15 in forum Mechanical & Bodywork
    Replies: 0
    Last Post: 06-12-2008, 12:08

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •