Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2018
    Location
    Hartlepool
    Posts
    5
    Liked
    0

    S15 no power or boost before 4krpm

    Really struggling to find anyone who has had this issue who has posted a solution in the last ten years or so. My car has next to no low end torque or power and boost holds off as the car crawls its way up past 4000rpm then it comes to life on full boost and start hauling ass. I've changed my knock sensor and a whole bunch of vac lines and now I'm looking at possibly changing the turbo gaskets and seeing if the timing is somehow shot. Checked the VCT Solenoid and it seems clean but I'm really struggling to come to grips with what's going on right now.

    Anyone got anything they can help with or know of someone who suffered similar issues? Any help would be awesome

    Thank you

  2. #2
    Join Date
    Jan 2013
    Location
    Kent
    Posts
    1,197
    Liked
    19
    Is it a stock engine/turbo/ecu? could be a combination of poor mapping and larger turbo, though for something that doesnt spool till 4k would have to be pretty large

    dou you have an AFR gauge as that will help to see if its running rich/lean and help to give a better idea of what is going on. Have you checked the plugs for colour and gap?

  3. #3
    Join Date
    Jul 2018
    Location
    Hartlepool
    Posts
    5
    Liked
    0
    Hey, nah the car is is completely stock other than a catback exhaust which was on it when it arrived. I don't have any gauges put in as of yet but it does seem to be getting poor mileage and no low down power. It hesitates under pressure when your climbing a hill at low revs too. Now I've searched high and low and check over a lot of components that would have done effect on the performance and economy and my first initial thought was that something is going on with my turbo and I think I've found the answer...

    Laaaaaaaaaaag .. Boooooooooost - Page 5

    Came across this old three with some others having the same issues except these guys found the answer. So I'm gonna have to find some time to remove the heat shield and see if something is up. If this is the case then I'll be a little pissed since I wondered if it was my wastegate from the get go but a friend of mine (big bad mechanical engineer) claimed it wouldn't make sense...this would not be the first time I've outsmarted him.

  4. #4
    DeanS15's Avatar
    DeanS15 is offline My car is so clean you could eat off it.
    This is DeanS15's Country Flag (England)
    Join Date
    Mar 2008
    Location
    sheppey, kent
    Posts
    2,968
    Liked
    16
    I would get the base timing checked as that can reduce power across the whole rev range and cause a lot of detonation that you might not notice. Then the usual check for boost leaks, make sure the actuator is good and worst case pull the turbo and check for gasket leaks and cracks around the manifold and exhaust housing coming out from waste gate aperture.

Similar Threads

  1. boost problem lack of power
    By fez06 in forum Mechanical & Bodywork
    Replies: 2
    Last Post: 04-12-2012, 16:58
  2. FS: Apexi Power FC + Boost controllerkit S15
    By Marco_v_w in forum Car Parts for Sale
    Replies: 7
    Last Post: 12-07-2012, 15:03
  3. How to adjust the boost on apexi power fc??
    By B9NKO in forum Mechanical & Bodywork
    Replies: 3
    Last Post: 04-02-2011, 08:21
  4. Power FC or boost controller
    By BOOSTED in forum Mechanical & Bodywork
    Replies: 19
    Last Post: 31-03-2009, 10:05
  5. What about The Boost Control Kit with Apexi Power FC??/
    By Albert in forum Electrical & Audio
    Replies: 2
    Last Post: 10-05-2006, 09:30

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •