Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2015
    Location
    Leeds
    Posts
    48
    Liked
    0

    Oil light with boost

    Hi Peeps,

    I have noticed that if I accelerate my S15. The oil light will come on after a certain boost pressure. I do not know if it is a certain rev range or a certain bar pressure that instigates the oil light to come on. Car has been de-mapped to 1.1 bar (not sure what that works out as in BHP) as it was pushing 380 bhp from its original JDM state. Any way the car can technically push more than what it does before the oil light comes on (under a Bar). Worried the engine is starved of oil or the sump simply runs low due to the stress. So as soon as light comes on I have started using this as an indicator to change gear now. Call me paranoid.

    Can any one explain, help, or suggest a modification to help me understand.

    Thanks

    Jack
    Last edited by Hairy Fish Nipples; 19-07-2015 at 22:24.

  2. #2
    DeanS15's Avatar
    DeanS15 is offline My car is so clean you could eat off it.
    This is DeanS15's Country Flag (England)
    Join Date
    Mar 2008
    Location
    sheppey, kent
    Posts
    2,972
    Liked
    16
    The oil pressure should actually be going up if you're revving the engine coming on boost, I'd check/change the sensor itself first as it's cheap. Do you have an oil pressure gauge - it's a good investment especially if it has a warning feature. That way you could see a drop in pressure when the lights coming on. As it would be fed by a different sensor it would be pretty conclusive its a bad stock sensor if there is no change when the light comes on... If it persists then it needs more looking into..

  3. #3
    Join Date
    Feb 2015
    Location
    Twickenham
    Posts
    278
    Liked
    0
    Yeah if the oil light is correct and you have low pressure then you've already experienced significant wear/damage, but it does sound unlikely given when its occurring. Could be worth checking your alternator and battery, as well as make sure grounds are in good condition and all connected properly.

  4. #4
    Join Date
    Feb 2015
    Location
    Leeds
    Posts
    48
    Liked
    0
    Hi Dean and Sibbers,

    Thanks for your input.

    I have since done an oil change and this has stopped it from happening.

    I will be replacing the sensor just in case. With regards to the Engine wear, it is a possibility, the engine had to recently be overhauled and re conditioned which was rubbish.

    It is possible other areas of the engine are also badly worn as it was just the cylinder block that was done.

    Thanks,

    Jack

Similar Threads

  1. WTB: Aero bumper plastic fog light mesh WITH NO FOG LIGHT HOLES
    By Jordan in forum Car Parts for Sale
    Replies: 0
    Last Post: 22-05-2013, 07:56
  2. L.E.D rear light + fog light
    By Cap'n Crash in forum Electrical & Audio
    Replies: 0
    Last Post: 13-10-2012, 14:58
  3. stock boost gauge light
    By sr20det in forum General S15 Chat
    Replies: 2
    Last Post: 27-02-2012, 14:19
  4. Dash Light's and boost back light????
    By J0R04N in forum Electrical & Audio
    Replies: 9
    Last Post: 05-10-2010, 05:50
  5. Back light on Boost gage not working
    By Rosscoss in forum Electrical & Audio
    Replies: 10
    Last Post: 04-10-2009, 17:53

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •