Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Join Date
    May 2014
    Location
    Warwickshire
    Posts
    83
    Liked
    0
    FIXED!

    Mixer flap had come disconnected!

    Warm air is so nice

  2. #12
    Join Date
    Feb 2011
    Location
    Chippenham, wiltshire
    Posts
    1,915
    Liked
    0
    Had to be that simple. These cars are bullet proof electrically. Its only when people mess with them that things break. No doubt got knocked off when someone was fitting something.

    S15 spec R Pearl yellow - Sold
    New JDM wagon.... Nissan Cube Autech Rider

  3. #13
    Join Date
    Dec 2019
    Posts
    5
    Liked
    0
    Iím having the same issue, where is this mixer flap and where was it disconnected?

  4. #14
    Join Date
    Aug 2011
    Location
    London
    Posts
    553
    Liked
    23
    I believe it's under the bonnet near the rear firewall

    Did you try this procedure first?
    JDM Digital Climate Control Diagnostic

  5. #15
    Join Date
    Dec 2019
    Posts
    5
    Liked
    0
    my climate controls are not the digital ones

Similar Threads

  1. Heaters are not working
    By vinnie in forum Electrical & Audio
    Replies: 14
    Last Post: 29-07-2014, 22:46
  2. Heater fan not working?
    By reepers13 in forum General S15 Chat
    Replies: 6
    Last Post: 27-02-2013, 18:06
  3. Speedo not working
    By Orb38 in forum Electrical & Audio
    Replies: 2
    Last Post: 24-02-2013, 14:05
  4. Lights not working
    By s15kid in forum Electrical & Audio
    Replies: 9
    Last Post: 20-08-2010, 12:51
  5. help need!!! over heating engine..
    By y2kfarrell in forum Mechanical & Bodywork
    Replies: 15
    Last Post: 02-04-2009, 21:01

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •