Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Join Date
    Nov 2005
    Location
    Hong Kong
    Posts
    2,704
    Liked
    0
    Ive got the panasonic speaker ive just powered my sub with a mono amp and just runing the standard speakers and its sounds good enough for me and iam very picky about my music quality

  2. #12
    RyanNK Guest
    Thanks for your input guys. The amp only puts out 45watts RMS per channel which I think the standard speakers could handle. Then the fith channel puts out 180watts RMS so im getting a 12" 200watt RMS sub.

    Anyone got custom installations in their cars? Wouldnt mind seeing some pics. I want to get a custom install thats plain and simple.

    Something like this.



    Post piccies if you have any

  3. #13
    Join Date
    Nov 2005
    Location
    Hong Kong
    Posts
    2,704
    Liked
    0
    nar mines just a huge box with the amp on the side on some none slip mats haha...

  4. #14
    Join Date
    Oct 2005
    Location
    Helsinki, Finland
    Posts
    8,001
    Liked
    5
    The standard setup is totally adequate for me. I feel that if you need to double the size of the speakers, fill the boot with a sub and amp, wire in a DVD player and Xbox, etc, etc - then you are spending FAR too much time in your car and need to get out a bit more....

    However, I am chief B.O.G. round here and just wouldn't understand...

  5. #15
    Join Date
    Nov 2005
    Location
    Moscow, Russian Federation
    Posts
    386
    Liked
    0
    Quote Originally Posted by Nicely
    However, I am chief B.O.G. round here and just wouldn't understand...
    ?B.O.G??
    Chris
    1999 S15 Spec S Auto (ever so slightly modified)
    1996 Skyline GTR (UK Holiday car); 2001 Lotus Esprit V8GT (moderate tuning); 2008 BMW 135i (looking for more power)

  6. #16
    Join Date
    Oct 2005
    Location
    Helsinki, Finland
    Posts
    8,001
    Liked
    5
    Quote Originally Posted by elizium
    ?B.O.G??
    Board Old Git.

  7. #17
    Join Date
    Nov 2005
    Location
    Moscow, Russian Federation
    Posts
    386
    Liked
    0
    Quote Originally Posted by Nicely
    Board Old Git.
    thanks for the clarification old man I think I remember when the internet was all just green fields, none of this fancy modern website development

    btw.. quick question for you - did your knocklink come with a sensor or was it an optional extra that I made the mistake of not purchasing?
    Chris
    1999 S15 Spec S Auto (ever so slightly modified)
    1996 Skyline GTR (UK Holiday car); 2001 Lotus Esprit V8GT (moderate tuning); 2008 BMW 135i (looking for more power)

  8. #18
    Join Date
    Oct 2005
    Location
    Helsinki, Finland
    Posts
    8,001
    Liked
    5
    lol! I remember when these fangled new computer things use cassettes to load up their 64K programs...

    If you paid for the ?149 kit, it should come with the sensor.

    Mine isn't working. Got to double check the power by hooking straight up to the battery, but looks like they will be replacing it. I treated the sensor as though it was in cotton wool too, so I definitely didn't bugger it.

  9. #19
    Join Date
    Nov 2005
    Location
    Moscow, Russian Federation
    Posts
    386
    Liked
    0
    Quote Originally Posted by Nicely
    lol! I remember when these fangled new computer things use cassettes to load up their 64K programs...
    64k... Luxury!! You must have been one of the rich kids :P Did bring back some funny memories of trying to get the damn tape recorder to load properly...

    I still remember thinking my mate was insane for wanting to have the 16k memopak for his zx81 - in fact I still do - having to type 16k's worth of code on that keyboard would have been enough to drive anyone over the edge


    Quote Originally Posted by Nicely
    If you paid for the ?149 kit, it should come with the sensor.

    Mine isn't working. Got to double check the power by hooking straight up to the battery, but looks like they will be replacing it. I treated the sensor as though it was in cotton wool too, so I definitely didn't bugger it.
    Just heard back from Thor - they pointed out I ordered the wrong thing (not the sensor) but he's going to give me the bosch part number and I should be able to source it locally.
    Chris
    1999 S15 Spec S Auto (ever so slightly modified)
    1996 Skyline GTR (UK Holiday car); 2001 Lotus Esprit V8GT (moderate tuning); 2008 BMW 135i (looking for more power)

Similar Threads

  1. WTB: Stereo Shelf
    By sliding-r in forum Car Parts for Sale
    Replies: 2
    Last Post: 30-12-2009, 01:42
  2. Stereo Problem
    By TrIcK^ in forum Electrical & Audio
    Replies: 9
    Last Post: 19-11-2009, 23:57
  3. What is my stereo setup?
    By Tilly in forum Electrical & Audio
    Replies: 14
    Last Post: 29-08-2009, 19:15
  4. S15 for sale on Ebay - thoughts?
    By Dan_Harris in forum General S15 Chat
    Replies: 11
    Last Post: 06-12-2008, 15:48
  5. HELP - Stereo Install
    By S15_Spec_R in forum Electrical & Audio
    Replies: 14
    Last Post: 19-07-2007, 14:36

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •