Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11
    Join Date
    Nov 2013
    Location
    Essex
    Posts
    370
    Liked
    12
    the Blitz probably won't leak so no real point checking that.

    do you have a front mount intercooler or standard wing mount?

  2. #12
    Join Date
    Apr 2013
    Location
    UK
    Posts
    45
    Liked
    0
    I have FMIC

  3. #13
    Join Date
    Nov 2007
    Location
    Sunny Tweed Heads
    Posts
    2,152
    Liked
    40
    The spring in the blow off valve can stick, you have to take it off and clean it out..put some very light oil on the piston

  4. #14
    Join Date
    Nov 2013
    Location
    Essex
    Posts
    370
    Liked
    12
    Quote Originally Posted by Auss15 View Post
    The spring in the blow off valve can stick, you have to take it off and clean it out..put some very light oil on the piston
    don't the blitz (like the SSQV) work in reverse to a normal BOV meaning the SSQV and blitz are unlikely to leak

  5. #15
    Join Date
    Nov 2007
    Location
    Sunny Tweed Heads
    Posts
    2,152
    Liked
    40
    Quote Originally Posted by hugh janus View Post
    don't the blitz (like the SSQV) work in reverse to a normal BOV meaning the SSQV and blitz are unlikely to leak
    Its not that it leaks it's the fact it can seize and the piston sticks..Here's a good how to for the Blitz..

    How To Blow Off Valve removal, cleaning, service and rebuild

  6. #16
    Join Date
    Jan 2013
    Location
    Kent
    Posts
    1,201
    Liked
    20
    i have this issue also in mine, I've noticed it a lot more now that im using it, mainly happens coming up to junctions/lights. as you back off the throttle and then into neutral just as you come to a stop the revs will drop to around 500- then either go back to idle or stall.

    I don't run a BOV so I'm assuming its the stalling air coming back out the turbo or whatever its doing that is causing it. could it be that the valve isnt opening enough/sticking shut causing the same issue? boost is about 0.7 bar currently

  7. #17
    Join Date
    Nov 2007
    Location
    Sunny Tweed Heads
    Posts
    2,152
    Liked
    40
    Have you checked you AAC valve isn't dirty and sticking ?

Similar Threads

  1. Random Boost Creep?
    By RagamuffinRyan in forum Mechanical & Bodywork
    Replies: 9
    Last Post: 26-01-2016, 20:56
  2. FS: S15 random parts
    By mattybyrne2008 in forum Car Parts for Sale
    Replies: 3
    Last Post: 02-01-2014, 18:20
  3. Loads of random S15 pics, might take a while : )
    By sliding-r in forum General S15 Chat
    Replies: 0
    Last Post: 22-12-2010, 20:37
  4. Random Plug/Sensor
    By mint in forum General S15 Chat
    Replies: 8
    Last Post: 26-07-2009, 08:38
  5. Random Irish S15
    By Ger Keane in forum General S15 Chat
    Replies: 18
    Last Post: 11-02-2008, 22:35

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •